logo DevMedia  
Home Entenda o site Revistas Canais Cursos Palestras Suporte Fórum +Serviços Assine Compre Créditos

Edição do Mês
  Fórum DevMedia
Fórum de Discussão
Conheça também o NOVO fórum da DevMedia, no endereço: www.devmedia.com.br/forum
O novo fórum possui diversas vantagens! Saiba mais em
www.devmedia.com.br/articles/viewcomp.asp?comp=14726
Estamos sempre trabalhando na melhora do site como um todo! Bons códigos!
Equipe DevMedia

 FAQFAQ   PesquisarPesquisar   MembrosMembros   GruposGrupos  RegistrarRegistrar   
 PerfilPerfil   Entrar e ver Mensagens ParticularesEntrar e ver Mensagens Particulares   EntrarEntrar 
Edição do Mês

Dúvida função .load() JQuery
 
Novo Tópico   Responder Mensagem    Fórum DevMedia - Índice do Fórum -> IDEs e frameworks
Exibir mensagem anterior :: Exibir próxima mensagem  
Autor Mensagem
patrickmaciel.info
Novato


Registrado em: Segunda-Feira, 11 de Mai de 2009
Mensagens: 1

MensagemEnviada: Ter Mai 12, 2009 12:12 am    Assunto: Dúvida função .load() JQuery Responder com Citação

Olá Gente, tudo joia?

Estou iniciando em JQuery (e também aqui no fórum), e tive uma dúvida, na qual, sei entre aspas a solução, porém é uma gambiarra, enfim, deixa eu explicar.

Eu tenho um link
Cita?:
Abrir pagina na div

<!-- nao consegui utilizar o href, por isso coloquei no ID -->


e um div onde vão ser carregadas as paginas, utilizando o JQuery.
Cita?:
<div id="conteudo">
as paginas serao abertas aqui
</div>


e a função JQuery
Cita?:
$(document).ready(function() {
$('a').click(function() {
$('#conteudo').load( $(this).attr('href') );

return false;
});
});


beleza, até então ok.
Porém acontece o seguinte, essa pagina1.html contém import de CSS, Javascript, AJAX, Imagens em geral, e ela esta em outro diretório como podem ver. As imagens, css, etc, estão em um diretório chamado public. por exemplo.:
Cita?:
<!-- codigo dentro da pagina1.html -->



concluindo, essa imagem não é carregada. Por que? Porque quando a pagina é enviada pelo método load para o DIV, esta entende que a pagina1.html esta na pasta raiz do site, então o caminho da imagem deveria ser:
Cita?:
<!-- codigo dentro da pagina1.html -->



Isso acontece com todos os caminhos que estão nas paginas. A única soluçao que encontrei foi colocar todas as paginas na pasta RAIZ. Mas eu gostaria de saber, porque o JQuery não consegue enxergar os caminhos?
Voltar ao Topo
Ver o perfil de Usuários Enviar Mensagem Particular Enviar Email MSN Messenger
Mostrar os tópicos anteriores:   
Novo Tópico   Responder Mensagem    Fórum DevMedia - Índice do Fórum -> IDEs e frameworks Todos os horários são GMT - 3 Hours
Página 1 de 1

 
Ir para:  
Enviar Mensagens Novas: Permitido.
Responder Tópicos: Permitido.
Editar Mensagens: Proibído.
Excluir Mensagens: Proibído.
Votar em Enquetes: Proibído.


Powered by phpBB © 2001, 2005 phpBB Group
Traduzido por: Suporte phpBB